いきあたりばったり

博多弁とオーディオネタ

2016年8月13日

Ubuntu 16.04 + mpcbridge

オーディオ, by take.akiyama.

Ubuntu の新しいLTSである16.04が出て3ヶ月程経ったので、インストールしてみました。

先に書いておくと、mpcbridgeは動きません。
Ubuntu 16.04のphpは、バージョン7になっています。

mpcbridgeのスクリプトの中でsplitという関数を使っている箇所があるのですが、php7では廃止されています。
http://php.net/manual/ja/function.split.php
この部分でエラーが発生します。

なお、mpdは、現時点で0.19.12が動いています。
とりあえずmpdが使いたいんだ!というかたには、ubuntu 16.04は、良い選択肢かもしれません。

Back Top

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です